Monday, January 21, 2013

PhoneGap Plugin Updates

In the past few days I've spent some time upgrading my plugins so they work in PhoneGap/Cordova 2.2.0 or greater without requiring the users to make any changes. I've done the FtpClient and VideoPlayer. Basically I'm removing any deprecation warnings by moving from the org.apache.cordova.api.Plugin class to the org.apache.cordova.api.CordovaPlugin class. Also, I've been moving to the cordova.require way of defining a plugin on the JavaScript side while retaining the old window.plugins object for people who've written their code to use this object.

I'm currently running a poll to see which of my plugins should get upgraded next so go please vote for your favourite:


I'll start picking them off as I have time this week.

9 comments:

Simon MacDonald said...

Not really a surprise that the BarcodeScanner is the leader by a wide margin.

Joshua Barth said...

What's the deal with the Android bluetooth plugin? I'm not sure the plugin even works, it is completely lacking documentation. It needs upgrading, please.

Simon MacDonald said...

@Joshua Barth

Sorry, I didn't write that plugin. Have you tried contacting the original author on GitHub?

Iandy Kochhar said...

ContactPicker - LegacyContext Depreciated (cordova.api.Plugin)

Hi,
I am using your Corinthian ContactPicker plugin for phonegap (cordova). Till Cordova 2.1.0 release everything was working fine, and when I updated to 2.3.0, I started getting an error (Error: org.apache.cordova.api.LegacyContext.startActivityForResult) whenever I tried to call the ConatctPicker plugin. I researched over the internet and cordova documents and found that now LegacyContext is depreciated in 2.3.0 for cordova.api.Plugin completely and so the plugin is not working. I am not a Java developer and so cannot update the code myself to fix the issue. Can you please fix this issue and post the fix?

Thanks
Iandy

Simon MacDonald said...

@Iandy Kochhar

Yes, I'll get to it as well. I just wish I have more time in my day to work on all of this stuff.

Julien De Almeida said...

Hi,

I need a plugin for unzip file into platform iOS, Android and Blackberry.

Any idea ?

Simon MacDonald said...

@Julien De Almeida

They are in the plugins repo:

https://github.com/phonegap/phonegap-plugins/tree/master/Android/ExtractZipFile
https://github.com/phonegap/phonegap-plugins/tree/master/iOS/ExtractZipFile

don't know of one for BB.

Tatyana Kitaygora said...

Please disregard the low vote on the TTS plugin: an update would be greatly appreciated!

Simon MacDonald said...

@Tatyana Kitaygora

Don't worry TTS will get updated. Probably over this weekend.